Troubleshooting
Problem
User launches Controller. User receives error message.
Symptom
An error occurred while trying to access the server.
Details:
Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
The request failed with the error message:
--
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>IIS 8.5 Detailed Error - 500.19 - Internal Server Error</title>
<style type="text/css">
<!--
<....>
</head>
<body>
<div id="content">
<div class="content-container">
<h3>HTTP Error 500.19 - Internal Server Error</h3>
<h4>The requested page cannot be accessed because the related configuration data for the page is invalid.</h4>
</div>
<div class="content-container">
<fieldset><h4>Detailed Error Information:</h4>
<div id="details-left">
<table border="0" cellpadding="0" cellspacing="0">
<tr class="alt"><th>Module</th><td> IIS Web Core</td></tr>
<tr><th>Notification</th><td> BeginRequest</td></tr>
<tr class="alt"><th>Handler</th><td> Not yet determined</td></tr>
<tr><th>Error Code</th><td> 0x80070775</td></tr>
<tr class="alt"><th>Config Error</th><td> Can not log on locally to f:\Program Files\ibm\cognos\ccr_64\webcontent as user <DOMAIN>\USERNAME with virtual directory password
</td></tr>
<tr><th>Config File</th><td> \\?\C:\inetpub\temp\apppools\Cognos\Cognos.config</td></tr>
</table>
</div>
<div id="details-right">
<table border="0" cellpadding="0" cellspacing="0">
<tr class="alt"><th>Requested URL</th><td> http://SERVERNAME:80/ibmcognos/controllerserver/CCRWS.asmx</td></tr>
<tr><th>Physical Path</th><td> f:\Program Files\ibm\cognos\ccr_64\ControllerProxyServer\CCRWS.asmx</td></tr>
<tr class="alt"><th>Logon Method</th><td> Not yet determined</td></tr>
<tr><th>Logon User</th><td> Not yet determined</td></tr>
Cause
There is a problem with the user account that is configured to run the relevant IIS (webserver) virtual directory.
Example:
In one real-life customer example:
- The IIS virtual directories 'cgi-bin' and 'ibmcognos' were configured to run under a local Windows user account
- That local windows account was 'locked out':
Account is locked out
Resolving The Problem
Fix:
Perform some/all of the following tasks (as necessary)
- Unlock the Windows user account that is mentioned in the error (for example <DOMAIN>\USERNAME)
- Reset the password for <DOMAIN>\USERNAME if you are unsure of its current value
- If you have changed the password for <DOMAIN>\USERNAME, update any process (or setting) that uses it
- For example, inside IIS, modify the username/password used to run any of the
Workaround:
Reconfigure IIS to use the default (built in) IIS account instead.
Example:
In one real-life customer example, the solution was to modify the IIS virtual directories ('cgi-bin' and 'ibmcognos') so that they run under the default IIS account
- Specifically, change the 'Connect As' setting to 'Application user (pass-through authentication)':
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Document Information
Modified date:
15 June 2018
UID
swg22000427