IBM Support

Error for missing fileset when trying to create a hpJetDirect print queue through smit

Troubleshooting


Problem

Receiving an error for missing software when trying to create a hpJetDirect print queue through smit/smitty, sometimes even when the necessary fileset is already installed

Symptom

Attempting to add a HP Jet Direct queue via smit/smitty fails with an error:

smitty --> Print Spooling -> Add a Print Queue -> hpJetDirect

The following screen is displayed:

This issue may occur for a system that has never previously had a printing configuration or for a system that previously had working hpJetDirect queues and was updated to a new AIX version or migrated.

Cause

This error may be caused by either the fileset really missing / not installed on the system, or due to some kind of corruption in the installed fileset.

The same error will be received in both cases.

Resolving The Problem

1) First check if the printers.hpJetDirect.attach fileset is installed on the system. This is the fileset required for hpJetDirect queues.

# lslpp -l printers.hpJetDirect.attach

If the above command returns output like the following, the fileset has to be installed from the AIX base media:


lslpp: Fileset printers.hpJetDirect.attach not installed.


The fileset can be installed from the AIX base media using the following method:

# smitty install_all

Select the appropriate source where the fileset is located (directory mounted from a NIM server, DVD, etc.) and then type the fileset name in the next menu and also change to accept license agreements, as shown below (make sure to capitalize the J and D in the fileset name).

2) If the fileset was already installed when running the lslpp command above, then likely the issue is caused by a change or corruption in the fileset itself.

We can use the following method to resolve this:


# grep add_queue /usr/lib/lpd/pio/etc/hpJetDirect.attach

If it looks like this:

add_queue = ps_not_installed_error_ghostName


Then do the following:

# vi /usr/lib/lpd/pio/etc/hpJetDirect.attach

# JetDirect attachment
description = piobe.cat,4,22;HP JetDirect Printer
Attached to Local System
seq_num = 5
add_queue = ps_not_installed_error_ghostName
add_printer = ps_not_installed_error_ghostName
submit_job = ps_qprt_fileName
change_queue = ps_chpq_attachName
change_filters = ps_pqfilters_ghostName
remove_queue = ps_rmpq_ghostname_jetdirect


Change the following lines :

add_queue = ps_not_installed_error_ghostName
add_printer = ps_not_installed_error_ghostName


Change them to:

add_queue = ps_makhp_prt
add_printer = ps_makhp_prt

After saving the above changes try to add the hpJetDirect queue again from smit/smitty.

If this still does not work, try to force-overwrite the fileset.

The method is the same as described above to install the fileset, with the difference that two more fields have to be changed in the install menu in addition to the above:


AUTOMATICALLY install requisite software? change to NO

OVERWRITE same or newer versions? change to YES

After this you should no longer be receiving the error when trying to create the queue.

[{"Product":{"code":"SWG10","label":"AIX"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Network communications","Platform":[{"code":"PF002","label":"AIX"}],"Version":"6.1;7.1;Version Independent","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

More support for:
AIX

Software version:
6.1, 7.1, Version Independent

Operating system(s):
AIX

Document number:
631501

Modified date:
17 June 2018

UID

isg3T1025443

Manage My Notification Subscriptions