IBM Support

Error Message,DDM20230E ERROR: The Cache server [Server Name] version cannot be verified. Windows error [0x80004003]: Invalid pointer

Troubleshooting


Problem

When you run the IBM DB2 Document Manager Desktop client on the Document Manager server, you see the following error: DDM20230E ERROR: The Cache server [Server Name] version cannot be verified. Windows error [0x80004003] In this scenario, the Document Manager Desktop client runs fine from remote workstations. The problem is only when you run it from the Document Manager server machine. Important: This technical support document is specific to the Windows error [0x80004003]. See the Related Information section for other possible causes for DDM20230E error messages.

Symptom

The dmlog.log file shows this error when tracing is enabled:

[EXC]: 04/15/2009 19:58:36.631 @ dm-srvr (10.10.10.10);  # DdmTraceLog
[USR]: User_name (C:\Documents and Settings\User_name) @ C:\Documents and Settings\User_name\Desktop
[THD]:      26c
[PRS]:      164
[MSG]: ERROR [80004003]: CDdmCacheNetClient::GetVersion - GetVersion
System.NullReferenceException: Object reference not set to an instance of an object.

Server stack trace:
   at DdmNetTr.DdmFileTransClientSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at DdmNetCS.DdmNetCacheServer.GetVersion(UInt32& ul1, UInt32& ul2, UInt32& ul3, UInt32& ul4, Int32& hResult)
   at DdmNetCC.DdmNetCacheClient.GetVersion(String netServerURL, String& cookie, UInt32& verMajor, UInt32& verMinor, UInt32& verBuild, UInt32& verPatch, Int32& hResult)
Server stack trace:
   at DdmNetTr.DdmFileTransClientSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at DdmNetCS.DdmNetCacheServer.GetVersion(UInt32& ul1, UInt32& ul2, UInt32& ul3, UInt32& ul4, Int32& hResult)
   at DdmNetCC.DdmNetCacheClient.GetVersion(String netServerURL, String& cookie, UInt32& verMajor, UInt32& verMinor, UInt32& verBuild, UInt32& verPatch, Int32& hResult)

[EXC]: 04/15/2009 19:58:36.631 @ dm-srvr (10.10.10.10);  # DdmTraceLog
[USR]: User_name (C:\Documents and Settings\User_name) @ C:\Documents and Settings\User_name\Desktop
[THD]:      26c
[PRS]:      164
[MSG]: GetVersion call failed (0x80004003)

Cause

This error is likely due to firewall software that is running on the DB2 Document Manager server that allows remote connections, but not a loopback connection.

Diagnosing The Problem

Temporarily disable the firewall software on the DB2 Document Manager server machine and see if you can successfully run the DB2 Document Manager Desktop client.

Resolving The Problem

You will need to add an exception to your firewall policy to allow a local loopback connection between the DB2 Document Manager Desktop client and the DB2 Document Manager server applications.

[{"Product":{"code":"SSDSNY","label":"Document Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Desktop","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;8.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21388720