Troubleshooting
Problem
An error message which appears on screen when trying to open a database in IBM i2 iBase can be easily resolved by changing the permissions to the folder.
Symptom
Error message transcript:
Failed to open the security file; ensure that it is not read-only.
(c:\FileLocation\iBasedatabase.ids)
Operation must use an updateable query.
Cause
The folder permissions where the .ids is located are set to read-only.
Diagnosing The Problem
In Windows Explorer go to the folder location shown in the folder in the error message.
Resolving The Problem
To change the permissions do the following:
- Right-click on the folder and click on Properties
- In the Security tab check that the users have permission to Write, Read and Modify.
- Click Apply
It should now be possible to log into the database without issue.
[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.5;8.9.1;8.9","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21694958