IBM Support

The error message "SQL1024N A database connection does not exist" occurs when you update the text index in IBM DB2 CommonStore for Lotus Domino V8.4

Troubleshooting


Problem

If you use any IBM® DB2® Content Manager Enterprise Edition V8.4 attributes for a full text search in IBM DB2 CommonStore for Lotus® Domino® V8.4, you will see the following error message: SQL1024N A database connection does not exist. SQLSTATE=08003. This error happens when you enable the text indexing timeout feature in the DB2 Content Manager system administration client.

Symptom

The following error message is shown in the DB2 Content Manager V8.4 item type event table output:

3 CTE0003 Index update started
100 CTE0100 A DB2 operation failed. DB2 information: "01H18" "[IBM][CLI Driver][DB2/NT] SQL0462W
Routine "*CHFILTER" (specific name "") has returned a warning SQLSTATE, with diagnostic text "icmxlsfc1: Error 61: General processing error in CMInterfac".  SQLSTATE=01H18
5 CTE0005 Index update commit: "707","0","0" documents inserted, updated, and/or deleted successfully.    
4 CTE0004 Index update ended  

The following error messages an be found in the icmfetchfilter log file:

icmxlsfc1: Error 61: General processing error in CMInterface. Function 'ICMFCECMInterfaceInit()' failed. 'SQL1024N  A database connection does not exist.  SQLSTATE=08003

' (rc: 3) [Origin: E:\cc_views\csbuild_ver_csall_8_4_0_24_zeus\csroot\cs_textsearch\icm_attrhandler\icmattr_sqlutils.cpp:84]2009/01/13 12:02:01.937[180] ++ icmxlsfc1: Error 61: General processing error in CMInterface. Function 'icmxls

Cause

There is a conflict between IBM DB2 CommonStore for Lotus Domino Version 8.4 and IBM DB2 Content Manager Enterprise Edition Version 8.4. One of the features of DB2 CommonStore for Lotus Domino V8.4 is that any DB2 Content Manager attribute can be added for a full text search. If you use this feature, and also enable text indexing timeout in the DB2 Content Manager V8.4 system administration client, you will encounter the error as described in the previous section.

Resolving The Problem

If you use any DB2 Content Manager V8.4 attributes for a full text search in DB2 CommonStore for Lotus Domino V8.4, then the setting enable text indexing timeout should not be selected in the DB2 Content Manager system administration client. Clearing the enable text indexing timeout check box might solve the problem.

The DB2 Content Manager V8.4 Information Center also contains related information about this conflict. See the Related information section for a link to the information center topic and view the section titled "Toleration of hang and stop during text indexing processing" for additional information.

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Document Information

More support for:
CommonStore for Lotus Domino

Software version:
8.4

Operating system(s):
AIX, Windows

Document number:
386211

Modified date:
17 June 2018

UID

swg21367150