IBM Support

Error message MSGSOCK007 with Access Client Solutions

Troubleshooting


Problem

Possible causes for receiving MSGSOCK007 error with Access Client Solutions. 1. Could Not Connect: (Connection Timed Out: Connect) 2. Could Not Connect: (Connection Refused)

Symptom

User receives MSGSOCK007 when using Access Client Solutions.

Cause

IBM i Access Client Solutions (IBM i ACS) will show the MSGSOCK007 error if there is a communications issue between the client and the server. It is likely the port the IBM i ACS client is trying to connect on is either not listening or connection is not reaching the IBM i OS System from across the network.

Environment

- IBM i Access Client Solutions

- IBM i OS 7.1 or higher

Resolving The Problem

Confirm which feature of IBM i Access Client Solutions (IBM i ACS) is giving the error and confirm which port that feature is attempting to connect to.

- 5250 emulator will be connecting to the following ports: 449, 23, 8470-8476.

- If SSL is enabled: 449, 992, 9470-9476

- Navigator for i will be using the following ports: 2004 (SSL enabled 2005).

- Please refer to the following document for TCP/IP ports required for IBM i Access and related Functions: http://www-01.ibm.com/support/docview.wss?uid=nas8N1019667

Use the NETSTAT command to confirm the ports are in a listening state on the IBM i OS System.

- Run NETSTAT from CL, take option 3, hit F14 (shift + F2) to show Local Port Column.

- Make sure required ports are in "Listen" state.

- If the required ports are not listed in a "Listen" state, the server application will need to be started on the iSeries.

If all required ports are in a "Listen" status, please use the following steps to confirm if the connection is reaching the iSeries.

- Run NETSTAT from CL, take option 3, hit F14 (shift + F2) to show Local Port column.

- Make note of the IDLE TIME for each port. The syntax is XXX(hours):XX(minutes):XX(seconds). This shows the last time a connection was made to this port on the IBM i OS System. Leave this screen up as you will need to come back to it. NOTE: Any connection to the IBM i OS System will reset the Idle Time. Please be aware that the Idle Time of a port may be resetting from another connection.

- Recreate the error: Try to connect again from the client giving the error.

- Go back to the NETSTAT screen and hit F5 to refresh. If the IDLE TIME on the required port(s) does not refresh, this shows the connection did not reach the iSeries. If this is the case, make sure the required ports are open across the network.

-NOTE: Not all ports of 8470-8476 (9470-9476 if SSL enabled) will be required for 5250 connection. For 5250 you MUST have ports 23, 449, 8470, 8475 and 8476 (449, 992, 9470, 9475 and 9476 if SSL enabled)

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Document Information

Modified date:
26 August 2021

UID

nas8N1022334