Troubleshooting
Problem
Using older Informix products, the following error message is displayed when an error is encountered:
<Error Number>: Cannot open file 'net.iem'.
For example,
29056: Cannot open file 'net.iem'.
Symptom
Using the finderr utility, it is apparent that the error message is incorrect.
$ finderr 29056
-29056 Gateway cannot rollback savepoint (error-message-info).
Cause
Legacy Informix products like Informix Enterprise Gateway Manager are built with older versions of Informix Client SDK. Older versions of Informix Client SDK have a message file called net.iem located in $INFORMIXDIR/msg/en_us/0333.
In newer versions of Informix Client SDK, the message file name is changed to cnet.iem.
Resolving The Problem
To resolve the problem, copy $INFORMIXDIR/msg/en_us/0333/cnet.iem to $INFORMIXDIR/msg/en_us/0333/net.iem and preserve the permissions and ownership of the file.
Document Location
Worldwide
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Document Information
More support for:
Informix Enterprise Gateway Manager
Software version:
All Version(s)
Document number:
6245796
Modified date:
10 July 2020
UID
ibm16245796