IBM Support

An error message appears when trying to open the database

Troubleshooting


Problem

Attempts to open the database using IBM i2 iBase results in the error Couldn't use file already in use

Symptom

Full transcript of error:

Couldn't use "; file already in use

Cause

This issue happens when you have not got write permissions to the folder where the IBM i2 iBase database is located.

Resolving The Problem

In order to resolve this problem you need to check the permissions on the folder where the .idb and the .ids files are located. You need to make sure that you have write permissions on the folder and the .ids and .idb files.

To check the permissions of the folder go to the folder where the database is located and do the following:

Microsoft Windows 7

  • Right click on the folder and select Properties
  • Select the Security tab
  • Check that your user name has got Full control of the folder and its files by looking at the Permissions for Users dialog box
  • If the Full control option is not ticked for your user click on Edit... and tick the Allow tick box for Full control and OK the changes.
  • Click OK again on the Security tab.

Now you should have access to the folder and its files and the error message should no longer appear.
[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.5;8.9.1;8.9;8.5;8.1;8.0;5.0","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

More support for:
i2 iBase

Software version:
8.9.5, 8.9.1, 8.9, 8.5, 8.1, 8.0, 5.0

Operating system(s):
Windows

Document number:
243855

Modified date:
16 June 2018

UID

swg21669266