Troubleshooting
Problem
Error 'Invalid username/password' encountered when accessing Oracle AQ using the WebSphere® Transformation Extender (WTX) Oracle® AQ® adapter.
Symptom
Error 'Invalid username/password'.
Cause
If the Oracle Client driver is not the same as the Oracle Server database version the WTX QA Adapter incorrectly modifies the password (of the username used to connect to the database) to all uppercase.
Environment
If there is a version mismatch connecting from an Oracle 10g client to an Oracle 11g database, which was configured with password sensitivity turned on.
Diagnosing The Problem
The Database Trace log contains the following error
<4452-5072>: Error (-1) returned by OCISessionBegin, errcode=1017
ORA-0107:invalid username/password:login denied username:
Also, if there is an Oracle version mismatch for example, connecting from an Oracle 10g client to an Oracle 11g database.
Resolving The Problem
Change the password to uppercase or please refer to APAR PM50979
Product Synonym
Ascential DataStage TX Mercator WTX
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Document Information
Modified date:
16 June 2018
UID
swg21568654