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Error: Failed to establish RPC connection to NuTCRACKER Service, when executing a ManualTest script from Rational TestManager

Troubleshooting


Problem

This technote explains how to resolve an error, Failed to establish RPC connection to NuTCRACKER Service, that might occur during IBM® Rational® TestManager® playback.

Symptom

The following error occurs when attempting to launch a ManualTest script from Rational TestManager:



    Failed to establish RPC connection to NuTCRACKER Service (error=1722).
    [rtmanager.exe (.\rpcinit.c:190) PID=5920 TID=2316]

Cause

The error was caused by the "NutCracker" service, which was not running.

Resolving The Problem

To resolve this issue:

  1. Go to the Microsoft® Windows® Control Panel and open "NutCracker".
  2. Click the "Services" tab and click "Start" and see if the current status says "Running".
  3. Next, open ManualTest and try running your script.

[{"Product":{"code":"SSSHVH","label":"Rational TestManager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Manual Test","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.1;7.0.1.1;7.0.0.3;7.0.1.2;7.0.0.4;7.0.1.3;7.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21295734