IBM Support

Error 'The Excel-link is not installed' using Excel 2007 or Excel 2010 caused by option 'Require Application Add-Ins to be signed by Trusted Publisher' being enabled

Troubleshooting


Problem

User clicks on the Excel button in Controller to log into Excel link. User receives error message "The Excel-link is not installed".
However, the Controller Link Add-In appears to have been installed correctly, for example:
1. Controller Excel link entry can (correctly) be seen in Control Panel->Add or Remove programs
2. In Excel 2007/2010, Excel Option -> Add-Ins, Controller add-in is (correctly) shown in Active Application Add-in list
3. In Excel 2007/2010, Excel Option -> Trust Center, click on Trust Center Settings, Macro Settings, both "Enable all macros (not recommended: potentially dangerous code can run)" and "Trust access to the VBA project object model" are (correctly) enabled.

Symptom


The Excel-link is not installed

Cause

There are many potential causes for the error 'The Excel-link is not installed'.
  • TIP: For more examples, see separate IBM Technote #1396195 and/or the separate IBM Technotes inside the 'related documents' section at the end.
 
This IBM Technote shall specifically deal with the scenario where the Microsoft Excel option 'Require Application Add-Ins to be signed by Trusted Publisher' is enabled:

This will stop the IBM Cognos Controller Excel add-in to be shown in the 'Add-in list', unless the location of the Controller client is registered inside Excel as a 'trusted location'.

Environment

This Technote assumes Microsoft Excel 2007 is installed on client device.
  • The instructions may need to be changed slightly for other versions of Excel.

Resolving The Problem

Fix:

Either:

(A) Upgrade to Controller 10.3.0 (or later) which includes a certificate that you can install

  • TIP: For more details, see separate IBM Technote #559583 .

or (B) Ensure that the location where the Controller client is installed is listed inside Excel's "Trusted Locations".

Steps for (B):

1. Launch Excel, and click on Microsoft Office Button
2. Click on Excel Option
3. Click on Trust Center
4. Click on Trust Center Settings
5. Select Trusted Locations
6. Click 'Add new location'
7. Browse and select the location where the Controller client is installed, for example:

8. Click 'OK' and exit Excel
9. Test.

Workaround:

Disable the Excel option "Require Application Add-Ins to be signed by Trusted Publisher".

Steps:

1. Launch Excel, and click on Microsoft Office Button
2. Click on Excel Option
3. Click on Trust Center
4 .Click on Trust Center Settings
5. Select Add-ins, uncheck (untick) "Require Application Add-Ins to be signed by Trusted Publisher":

6 .Click 'OK' and exit Excel Option
7. Exit Excel, then log in again. The add-in menu will show with Controller link in the list.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0;10.1.1;10.1;8.5.1;8.5","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1042143

Document Information

Modified date:
17 June 2020

UID

swg21362039