Troubleshooting
Problem
This technote describes the error, "cqaxrform.ocx failed to register". This occurs during the installation of IBM® Rational® ClearQuest® on a Microsoft® Windows® operating system.
Symptom
When installing or updating ClearQuest, it is possible for one or more .ocx or .dll files to fail registration. Here is an example of such an error:
Error 1904. Module C:\Program Files\Rational\ClearQuest\cqaxrform.ocx failed to register. HRESULT 3
Cause
There are multiple causes for this problem:
- There are existing Rational products on the machine that may be accessing the .ocx files.
- There may be conflicting versions of the Rational products installed on the machine.
- The anti-virus program was not disabled during installation.
- There is a high level of security on the machine that prevents the Installer from registering files.
Resolving The Problem
Assure that all core Rational products installed on the machine are installed as the same base version or release. See technote 1251131 for more details in that regard. Should other Rational products be installed, all related Windows services should be disabled prior to installing or updating. Additionally, if integrated with other Rational products, use Windows Task Manager to make sure there are no CQIntServer processes running before running the installer.
Users should also make sure that the anti-virus is disabled during installation or updating.
In the event that the installer was not allowed to register the file due to high security, try to manually register the file:
- Go to the Windows Start button, then select Run
- Type in the command:
regsvr32 C:\Progra~1\Rational\ClearQuest\cqaxrform.ocx
then click the OK button.
Note: This command assumes that ClearQuest is installed in the default directory. - You should get a message that the file was successfully registered.
- If you get an error such as:
or
LoadLibrary ("C:\Progra~1\Rational\ClearQuest\cqaxrform.ocx")
failed -- Could not find procedure
LoadLibrary ("C:\Progra~1\Rational\ClearQuest\cqaxrform.ocx")
failed - The specified module could not be found.
Then verify that the file exists in the directory specified. - If an older version of the file is conflicting with the needed file, try to unregister the existing file first prior to manually registering. Use the regsvr32 /u /s <File Name> command to perform an unregistering. The /u argument denotes the unregister function, and /s suppresses unneeded messages.
- In the event of further problems, make sure that the folder that the file resides in is in the system path.
- Once the file is registered, restart the machine and rerun the ClearQuest install program. This time the installation should complete.
- If this step does not work, please speak with the system administrator to have the machine's security settings temporarily lowered for installation.
Users can repair the installation via Add/Remove Programs, or reinstall to assure the proper registration after engaging troubleshooting measures.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21208173