IBM Support

Error 'Attempted to read or write protected memory' when trying to run forms

Troubleshooting


Problem

Inside Controller, user clicks on 'Reports' - 'Run'. They select a report, and the variables, and click on 'send to application'. After a few seconds, they receive an error. If they try to close this error, then they receive further error messages.

Symptom

Initial Error:

Example #1:

    Microsoft Office Excel has encountered a problem and needs to close. We are sorry for the inconvenience.
    If you were in the middle of something, the information that you were working on might be lost.
    Debug Close

Example #2:
    Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Further errors after clicking OK:

Example#1:
    IBM Cognos 8 Controller Link
    Specified OLE variant is invalid
    OK

Example#2:
    Information
    Standard Error
    Number: -2147023170
    Source: Microsoft.VisualBasic
    Description: The remote procedure call failed. (Exception from HRESULT: 0x800706BE)

Example#3:
    Number: -2147417851
    Description: The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

Cause

Code production problem in versions 8.2.384 - 8.2.391 inclusive.

Environment

Typically the report will run OK when the client device has Microsoft Internet Explorer 6 (IE6) installed. However, immediately after upgrading to Internet Explorer 7 (IE7 (no other changes) the same report will fail.


NOTE: This problem has also (but rarely) been seen when running Controller on a PC with Internet Explorer 6 installed.

Resolving The Problem

Fix:
Upgrade to Controller 8.2sp6 (also known as release v8.2.43.30 and 8.2.392 inside 'help - about') or later.

Workarounds:

  • Downgrade client device (for example user's PC or Citrix server) from IE7 to IE6
    • TIP: Do this by using Add/Remove Programs to uninstall Internet Explorer 7
  • Afterwards, add the Controller server to the 'trusted zone', and reduce the security of this zone to 'medium' or lower.
    • TIP: Do this inside Internet Explorer by clicking on 'Tools - Internet Options' and add the Controller server to the 'trusted zone' and ensure that the security of this zone is 'medium' or lower

Alternatively, the following potential workaround has had limited success with customers.

  • Keep IE7 installed, but:
    • add the Controller server (for example http://servername) to the Internet Explorer's 'trusted zone'
    • reduce the security of this zone to 'medium-low'
  • TIP: For steps on how to do this, see separate IBM Technote #1347295.

NOTE: this second/alternative potential workaround may not work in all environments.

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Historical Number

1035212

Document Information

Modified date:
15 June 2018

UID

swg21347360