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Troubleshooting
Problem
Attempting to open a Microsoft Excel file using the Import Tool in IBM i2 Analyst's Notebook results in a Microsoft OLEDB error message appearing.
Symptom
Depending on the action you are taking or your version of i2 Analyst's Notebook, you could get either of the following messages:
- "The Microsoft.ace.OLEDB.12.0 provider is not registered on the local machine."
- "Cannot open Data File. Make sure Microsoft Access Database Engine 2010 or higher is installed
You may be able to successfully import files by saving them as .xls or .csv files in Microsoft Excel prior to import. Renaming the file extension will not suffice.
Cause
An additional Microsoft Access Database Engine redistributable package has not been installed on the machine. This package contains, amongst other things, OLEDB drivers which are used by IBM i2 Analyst's Notebook.
Environment
This problem occurs when IBM i2 Analyst's Notebook installed alongside Microsoft Office.
Resolving The Problem
The problem can be resolved by downloading and installing the following redistributable package which depends on the version of Microsoft Office installed:
Because i2 Analyst's Notebook is a 32-bit application, be sure to download the 32-bit version of the code: AccessDatabaseEngine.exe
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"ARM Category":[{"code":"a8m50000000Cb3AAAS","label":"i2 Analyst's Notebook and other i2 software->Import\/Export"}],"ARM Case Number":"TS004383477","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]
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Document Information
More support for:
i2 Analyst's Notebook
Component:
i2 Analyst's Notebook and other i2 software->Import/Export
Software version:
All Version(s)
Operating system(s):
Windows
Document number:
236355
Modified date:
30 October 2020
UID
swg21661956