IBM Support

Error: Another user is currently generating a Microsoft Word HTML document, in RequisiteWeb

Troubleshooting


Problem

This technote documents why the following error, "Another user is currently generating a Microsoft Word HTML document. Try again in a few minutes." may appear in IBM Rational RequisiteWeb.

Symptom

The full error message is as follows:

An error has occurred:                                                  

Unable to verify if the HTML Document needs updating:java.lang.          

Exception: Unable to generate the HTML document:java.lang.Exception:    

Another user is currently generating a Microsoft Word HTML document. Try again in a few minutes.

Document path names:                                                              
Source directory: <path to project directory>

Temp directory:<install drive>:\Program Files\IBM\RationalSDLC\profiles\profile2\installedApps\DefaultNode\ReqWeb.ear\ReqWeb.war\GenDoc\<document's temp directory>\

Destination directory:<install drive>:\Program Files\IBM\RationalSDLC\profiles\profile2\installedApps\DefaultNode\ReqWeb.ear\ReqWeb.war\GenDoc

Destination HTML path:/ReqWeb/GenDoc/<document's temp directory>/<document name>.html

Document path names:                                                              
Source directory: <path to project directory>

Temp directory:<install drive>:\Program Files\IBM\RationalSDLC\profiles\profile2\installedApps\DefaultNode\ReqWeb.ear\ReqWeb.war\GenDoc\<document's temp directory>\

Destination directory:<install drive>:\Program Files\IBM\RationalSDLC\profiles\profile2\installedApps\DefaultNode\ReqWeb.ear\ReqWeb.war\GenDoc

Destination HTML path:/ReqWeb/GenDoc/<document's temp directory>/<document name>.html      

                                     
Click here to reset page and continue.                                            
- or -                                                                            
Click here to return to Project Properties page.

Cause

On a RequisiteWeb server, only one document can be generated at a time.

Resolving The Problem

The above message appears when there is currently a document being generated. The error can appear in a few different scenarios. The message is expected in the following scenarios and is working as designed.

  • If there are two users trying to open the same document or different documents, the second user will get the message above. As the error message suggests this user should try again later when the server is not busy generating a document.
  • If one user clicks on one document, and then immediately clicks on a different document before the first has completed generating, the message will appear.
  • In RequisiteWeb versions prior to 7.1, this error also occurred when a user double clicks on a document. This is because a single click will open the document, and the second click will try to open the document a second time resulting in the message. In RequisiteWeb 7.1 changes have been made to enhance the usability. RequisiteWeb now checks for double clicks when opening a document so if a user double clicks, they will be able to open the document successfully.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Word Integration: Document open\/close\/save","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.1;7.1.0.1;7.1.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21393896