IBM Support

Error 908 when connecting to a database server

Troubleshooting


Problem

You try to connect to a database server but receive error -908: -908 Attempt to connect to database server (servername) failed.

Symptom


-908 Attempt to connect to database server (servername) failed.

Cause

  • instance is offline
  • connection information is incorrect
  • various other causes not limited to above list

Diagnosing The Problem

  • Run onstat -g to check the instance status.
  • Check your environment variables, ONCONFIG file, setnet32 settings, services file and sqlhosts to make sure your connectivity related information is consistent and correct.
  • Make sure you can ping from the server machine from the client machine

Resolving The Problem

  • Run oninit to bring database server online.
  • Correct connectivity related information; INFORMIXSERVER, port number, hostname, and so on
[{"Product":{"code":"SSGU8G","label":"Informix Servers"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF022","label":"OS X"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.5;11.7;12.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

More support for:
Informix Servers

Software version:
11.5, 11.7, 12.1

Operating system(s):
AIX, HP-UX, Linux, OS X, Solaris, Windows

Document number:
130587

Modified date:
23 June 2018

UID

swg21409402

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