Troubleshooting
Problem
While using the IBM Informix JDBC driver to retrieve blobs, you get error -79701 "Blob not found".
Symptom
While using the IBM Informix® JDBC driver to retrieve blobs, you get error -79701 "Blob not found".
Cause
Error -79701 is given when the IBM Informix® JDBC driver gets an error while trying to access temporary files for caching blob data.
To find out if disk access is the cause of the problem, set the connection property LOBCACHE to -1. If the error does not reoccur, then you know a problem with disk access caused the error.
Important: This is not the only possible cause of the problem.
Resolving The Problem
The most common reasons that the driver could not write files are:
- The user the java program is running as does not have the right system permissions for the directory it is writing to.
- There is not enough disk space.
The IBM Informix JDBC driver will use the current directory for temporary files (including the cache files) by default. You can change the directory used to store temporary files by setting the connection property JDBCTEMP.
You can also tell the JDBC driver to cache all blob data in memory instead of files by setting LOBCACHE to -1.
See the IBM Informix JDBC driver manual for information on setting LOBCACHE and JDBCTEMP.
Was this topic helpful?
Document Information
Modified date:
20 January 2022
UID
swg21152782