Troubleshooting
Problem
Symptom
There is no license for IBM SPSS Statistics. This could be due to a missing license file or no more network licenses available. For detailed information about this problem, run the 'showlic' utility found in the product installation directory.
Execution of this command stops.
Specific symptom number: 18
Cause
Diagnosing The Problem
If you cannot find this file in the directoriers below, it means that file was not created due to limited permission for your user's account on the PC. Sometimes you may see that LAW is indicating successful authorization but
- there is no lservrc file.
- If the file is there but it only contains " " sign, it means that LAW was not able to overwrite the file due to permission issues. Typical lservrc containing license key looks in this format:
A1B2C3D4E5F6G7H8I9J0K1L2M3N4O5P6Q7R8S9T0U1V2W3X4Y5Z6A7B8C9D0E1F2G3H4# "1200" version "250", expires Midnight of Jan 31, 2020, exclusive
Resolving The Problem
- On Windows 10 issue may be caused by insufficient privileges granted to the account. You may try to take full control of SPSS installation directory
MacOS
In typical scenario authorization code is accepted, lservrc file is populated but SPSS product still cannot run properly (There is no license for SPSS product). This can happen on some MacOS systems when you have a lock code starting with 10-.
1) Open up FINDER
2) Open up the APPLICATIONS folder
3) Open up the IBM folder
4) Open up the SPSS folder
5) Open up the Statistics folder
6) Open up the folder for version of product
7) Locate the "SPSS<product>.app" (application bundle) right click, and choose "Show Package Contents".
8) Open up the "Contents" folder
9) Open up the "bin" folder
10) Locate and Control Click the file echoid.dat and choose Open With, and then choose to open it with TextEdit.app (pre-installed on a Mac below Applications\Utilities folder)
11) Change the value in the file echoid.dat from 0x010 to 0x004
12) Save the echoid.dat file with same name
13) Delete the current license file LSERVRC file in this directory (if one exists, if not continue)
14) Run the License Authorization Wizard of SPSS on /Applications/IBM/SPSS/<product>/<version>/ while the computer is connected to the internet . Make sure you see a lock code that begins with 4- on the wizard now. Use the same 20 digit authorization code you got before.
15) REBOOT the Mac.
16) Then launch SPSS product. The software should now launch without error.
Related Information
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Document Information
Modified date:
18 May 2021
UID
swg21623152