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Error 53 reported when viewing .doc, .pdf document types in IBM i2 iBase Document-Fields

Troubleshooting


Problem

When reviewing an iBase entity, in an IBM i2 iBase datasheet; Word and pdf documents in the Document field fail to display within the IBM i2 iBase viewer and an error 53 is reported if you try and view the document.

Symptom

IBM i2 iBase fails to display .pdf and .doc/.docx document types in the viewer when displaying document entity field records within IBM i2 iBase. This is when using the right mouse click, view option on the document field of the entity.

Cause

incorrect field permissions on the iBase temp directory

Diagnosing The Problem

For the document entity, The document icon field will be blank/white. Plus if you try to view the document then a 'File not found' message is given and in the error details the message Error , 'Error 53 occurred in id5Error idRecordCard:image_MouseDown' is recorded/reported.


Resolving The Problem

1.) Change the security permissions on the iBase temp folder to allow 'Read & execute','List folder contents', 'Read'.


2.) You must stop and restart iBase for the changes to take effect.
3.) Examination of the iBase temp directory will show the creation of individual idtmp<user>nnnnnnn.PDF or idtmp<user>nnnnnnn.DOC files with a file size greater than 0 KB. (Once the correct changes have been made for the permissions).


[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.11","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21992912