IBM Support

Error 1904: Unable to register RqXMLConversion.dll, when installing RequisitePro

Troubleshooting


Problem

This technote explains why the error, Unable to register RqXMLConversion.dll, occurs when installing IBM® Rational® RequisitePro® but you are still able to click OK continuing the installation and being able to launch RequisitePro without any errors.

Symptom

If you try to manually register RqXMLConversion.dll, it still fails to register.

Cause

There are one or more than one DLL files in the <drive>\Program Files\Rational\RequisitePro\Bin directory that need to be re-registered prior to registering RqXMLConversion.dll.

Resolving The Problem

To re-register all the DLLs in the <drive>\Program Files\Rational\RequisitePro\Bin directory use the following instructions:

  1. Open up a command prompt by selecting Start > Run..., type in CMD and click OK

  2. Change directories to <drive>:\program files\rational\requisitepro\bin:

    cd <drive>:\program files\rational\requisitepro\bin  

  3. Enter the following command and hit Enter:

    for %i in (*.dll) do regsvr32 %i /s 

  4. Once the DLLs are re-register, now register RqXMLConversion.dll by typing in the following at the command prompt:

    regsvr32 RqXmlConversion.dll

  5. When complete, you will receive a message stating the DLL was successfully registered.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.1;7.0.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21297805