IBM Support

Error 1714 received during the Client upgrade

Troubleshooting


Problem

Tivoli Storage Manager Client upgrade fails and issues following error even after uninstalling and removing the older version completely. Error 1714. The older version of IBM Tivoli Storage Manger Client Cannot be removed.

Cause

The older version of the Tivoli Storage Manager Client is not properly uninstalled and registry entries still exist.

Resolving The Problem

Even though the older version of Tivoli Storage Manager Client is uninstalled and removed completely, a Tivoli Storage Manager Client upgrade still fails with the following error:



Following are the steps to resolve the above error:

1. Download and install the Windows Installer CleanUp Utility from the following Microsoft link.

http://support.microsoft.com/mats/Program_Install_and_Uninstall

This utility is used to remove installation information for programs that were installed by using Windows Installer. Be aware that Windows Installer CleanUp Utility will not remove the actual program from your computer. However, it will remove the installation files so that you can restart the installation, upgrade, or uninstall.

2. Start the "Windows Installer Cleanup" from Start --> Programs.

3. Find and Remove the Tivoli Storage Manager Client.

4. Retry the Tivoli Storage Manager Client installation.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21327235