IBM Support

Enhanced Services Not Starting When Using STRFAXSPT Command in Startup Program

Question & Answer


Question

The QSTRUP startup program was changed to call the Start Fax Support (STRFAXSPT) command. After IPLing the IBM i system, faxes are shown in a "Waiting to Create" status. The system administrator was unable to find messages related to Facsimile Support/400 (FAX/400).

Cause

The Work with Active Jobs (WRKACTJOB) command and scrolling down to the QFQSBS subsystem jobs showed that not all of the expected Enhanced Services jobs were running; for example, QFQSNDSTS, QFQRCVDSP, QFQFAXSRV, and QFQCLEANUP. There were two copies of the STRFAXSPT command on the iSeries family system, in libraries QFAX and QSYS as expected. However, both commands had the Enhanced Services (ENHSRV) parameter set to the default value of *YES.

Answer

Any user profile that runs the Start Fax Support (STRFAXSPT) command must has both *SPLCTL and *JOBCTL special authorities, and must be setup as a fax administrator under the Work Fax Profiles (WRKFAXPRF) command.

The QSTRUP program runs under the QPGMR user profile, but the Work with User Profiles (WRKUSRPRF) command showed that the QPGMR user profile did not have *SPLCTL and *JOBCTL special authorities, and the Work Fax Profiles (WRKFAXPRF) command showed that the QPGMR user profile was not set up as a fax administrator.

The QPGMR user profile was given *SPLCTL and *JOBCTL special authorities and was set up as a fax administrator, and that resolved the problem.

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Platform":[{"code":"PF012","label":"IBM i"}],"Version":"6.1.0"}]

Historical Number

392064317

Document Information

Modified date:
18 December 2019

UID

nas8N1019837