IBM Support

End User sees profile attribute as non-editable in self console

Troubleshooting


Problem

An ACI has been added for user, granting read and write permissions to the person attribute that's on the form, and Modify operation is granted. When checking the attribute on the form, it's not read-only on Modify. The end user sees this attribute as non-editable in the self console (Self Service User Interface, aka SSUI).

Symptom

End User logs into self console, clicks on 'View or Change Profile', and the person attribute that has ACI configured for, is not editable.

Cause

By default, the 'End User View' has 'Change My Personal Profile' box unchecked, under 'Self Service Console' section.

Diagnosing The Problem

Review the view, in the ITIM console under 'Set System Security' -> 'Manage Views'.

Resolving The Problem

Check box the 'Change My Personal Profile' in 'End User View', under 'Self Service Console'.

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Product Synonym

TIM ITIM ISIM SIM Identity Manager

Document Information

Modified date:
16 June 2018

UID

swg21616346