IBM Support

Enabling IBM FileNet Content Engine server tracing

Question & Answer


Question

How to enable and collect trace logs for the Content Platform Engine server.

Cause

While troubleshooting problems it may be necessary to collect detailed tracing information for support.

Answer

Enable and collect server trace files for support:
  1. Optional: shut down each CPE server and purge any preexisting trace and error files, either: (V5.5.5 and earlier) p8_server_trace*.log and p8_server_error.log; or (V5.5.6 and later) ce_trace*.log, and ce_system0.log.
  2. Enable one or more CPE trace subsystems using the Administration Console for Content Platform Engine (ACCE).
  3. Reproduce the problem or error for which the trace logs are being collected.
  4. Disable tracing in ACCE.

The minimum trace subsystem required to troubleshoot a problem is Error.
Do not leave tracing on all the time. It may slow the system down significantly.
Do not turn on tracing for all subsystems. This will result in a severe performance degradation. 
Only enable those subsystems listed in the appropriate tech note or on advice from your support representative.

Trace control with ACCE:

Trace logging can be controlled using ACCE at the server instance, the virtual server, the site, or the domain levels. Although trace logging is most commonly enabled at the Domain level (especially in clustered configurations), the server adheres to the following order of precedence when determining what subsystems are enabled for tracing: lower levels take precedence over higher levels.

Trace configuration order of precedence:  Server Instance > Virtual Server > Site > Domain
Unless you have a valid reason to enable CPE trace logging on one of the more specific levels, we suggest that you enable it only on the Domain level.  Other levels are easily overlooked, the Domain level is easy to access, and IBM Support most often requires trace logs from all CPE servers in the domain.

To enable trace logging at the appropriate level:
Domain: On the domain node, select the Trace Subsystem tab.
Site: In the ACCE object tree, expand [Domain] > Global Configuration > Administration > Sites > [Site-name] > Trace Subsystem tab
Virtual Server: In the ACCE object tree, expand [Domain] > Global Configuration > Administration > Sites > [Site-name] > Virtual Servers > [Virtual-Server-name] > Trace Subsystem tab
Server Instance: In the ACCE object tree, expand [Domain] > Global Configuration > Administration > Sites > [Site-name] > Virtual Servers > [Virtual-Server-name] > [Server-Instance-name] > Trace Subsystem tab
You can enable or disable all available trace logging components either collectively or independently.

Once a Trace Logging component is found at a given level, that component is used for all subsystems. For example, if EJB tracing is enabled at the Server Instance level for server myServer and Database tracing is enabled at the Domain level, then the trace log file on myServer will contain EJB tracing, while all other servers in the P8 Domain will contain Database tracing.

To enable or disable components for trace logging, perform the following procedure:
  1. Open the Trace Subsystem tab from one of the entry points.
  2. If configuring tracing below the Domain level, select "(this object)" for the Configuration Source value
  3. Click Enable Trace Logging or Disable Trace Logging.
  4. After enabling trace logging, select the desired components individually, or use the Set/Clear All Flags checkbox to select all components.
  5. Click Save.

Collecting trace files

By default, the trace files are produced on each application server in the following locations:
V5.5.5 or earlier:
  • WebSphere
    <install-root>/profiles/<profile-name>/FileNet/<server-name>/p8_server_trace*.log
  • WebLogic
    <install-root>/user_projects/domains/<domain-name>/FileNet/<server-name>/p8_server_trace*.log
  • JBoss
    <install-root>/bin/FileNet/<server-name>/p8_server_trace*.log

V5.5.6 or later:
  • WebSphere
    <install-root>/profiles/<profile-name>/FileNet/<server-name>/ce_trace*.log
  • WebLogic
    <install-root>/user_projects/domains/<domain-name>/FileNet/<server-name>/ce_trace*.log
In a cluster environment, collect the log files from each server.

See the FileNet P8 Platform documentation at Content Platform Engine log files for more information about server tracing.

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Document Information

Modified date:
16 September 2024

UID

swg21308282