IBM Support

Enablement test fails for Chrome browser under Rational Functional Tester

Troubleshooting


Problem

Attempts to enable the chrome browser for a test results in Java Plug-in failure under IBM Rational Functional Tester (RFT).

Symptom

Warning Message:

"Java(TM) was blocked because it is out of date" with option "update plug-in" and "Run this time"
"Java plug-in is needed your permission to run" with option "Run this time" and "Always run on this website"

Cause

Java plug-in is not correctly enabled for the respective browser.

Resolving The Problem

There are two possible solutions for this issue:

Solution 1:



Add the following commands in Chrome shortcut properties:

 C:\Users\IBM_ADMIN\AppData\Local\Google\Chrome\Application\chrome.exe -allow-outdated-plugins --allow-file-access-from-files -always-authorize-plugins




Solution 2:
  1. Add the chrome executable in Application configuration Tool under RFT.
  2. Add the following command line parameters as Arguments under Application configuration Tool.

    --allow-outdated-plugins --allow-file-access-from-files -always-authorize-plugins application url



    Example:

    --allow-outdated-plugins --allow-file-access-from-files -always-authorize-plugins www.google.com

Internal Use Only

This technote was generated by Technote Kickstart 1.1.0.11 based on Rational Customer Support PMR 90849,999,744.
View the associated PMR's text via Wellspring at: http://eclient.lenexa.ibm.com:9082/DocFetcher/source/PMR/90849.999.744%20O13/05/21

[{"Product":{"code":"SSJMXE","label":"Rational Functional Tester"},"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Component":"Test Environments","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;8.3.0.2","Edition":""}]

Document Information

Modified date:
16 June 2018

UID

swg21639796