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Enable an SDS trace for Cognos Analytics 11.0.7+

Question & Answer


Question

How to enable an SDS trace for Cognos Analytics 11.0.7+ ?

Cause

The steps to enable a SDS trace in Cognos Analytics 11.0.7 and upwards is different as there is no ipfSDSclientconfig.xml.sample file in the \configuration directory of the Cognos installation in Cognos Analytics 11.0.7 and future versions.

Answer

Steps:

  1. Open Cognos Analytics in a browser.
  2. Click on Manage -> Configuration -> Diagnostic logging.
  3. Under "Built-in topics" click on "Show all".
  4. Select "SDS" from the list and click on "Apply".
  5. Reproduce the issue.
  6. Logging will usually be captured in cognosserver.log

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.7+, 11.1.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 March 2019

UID

ibm10715539