IBM Support

EIM domain missing in IBM Navigator for i (Web-based GUI)

Question & Answer


Question

Using IBM Navigator for i web-based GUI, the EIM domain and its contents are missing. It might be seen in the iNavigator Windows-based GUI though.

Cause

A missing domain can happen when the EIM domain was created by someone else or by the same user that used the old IBM i Navigator (i Access for Windows).

Answer

When you are working with the IBM Navigator for i and EIM and did not create the EIM domain by using the web-based GUI (graphical user interface), the EIM domain might be missing. If the EIM domain exists but does not show in the GUI, then the domain needs to be added.

To add the EIM domain, open the GUI path:

Network > All Tasks > Enterprise Identity Mapping > Domain Management

...then click "Add Domain".


"Add Domain" location

If you know the EIM domain name, add it manually or click "Browse" to find it. You might be prompted to enter the administrator name and password. The password is normally the LDAP administrator password that was used when EIM was configured.



Select the EIM domain to add.

After the domain is added, you might need to connect, or reconnect to the domain.

To connect to the domain, select "Domain Management", right-click the EIM domain name and select "Connect" or "Reconnect". You can be prompted to authenticate again. After you are connected, you can open up the EIM domain and view or manage the identifiers.


Right-click the EIM domain and select "Connect" or "Reconnect".
 

Righ click the domain and select the "Open" option.


You should be able to see and manage the contents of the EIM domain.

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CGrAAM","label":"Single Sign On"},{"code":"a8m0z0000000CJ7AAM","label":"Single Sign On->Enterprise Identity Mapping"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"},{"Product":{"code":"SSTS2D","label":"IBM i 7.3 Preventative Service Planning"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Product":{"code":"SSC5L9","label":"IBM i 7.2 Preventative Service Planning"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Product":{"code":"SSC52E","label":"IBM i 7.1 Preventative Service Planning"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]

Document Information

Modified date:
23 November 2021

UID

nas8N1021913