Troubleshooting
Problem
It may be necessary to trace a Tivoli Storage Manager storage agent while it is running. Inserting trace statements in the dsmsta.opt file as directed by the problem determination guide requires to stop and start the agent.
Cause
Need a way to trace the agent without having to stop/restart it.
Resolving The Problem
There are 2 ways to dynamically issue trace commands to the Tivoli Storage Manager storage agent. The below examples use an agent name of STAGENT1 with a tcp/ip address of 192.168.101.2 and port of 1501.
Method 1 :
Use the Tivoli Storage Manager administrative command line and connect directly to the storage agent ip address and ip port. For example, using a windows admin command line, issue :
dsmadmc -tcps=192.168.101.2 -tcpp=1501
For a unix admin command line, you would create a new stanza in the dsm.sys (STAGENT1) and connect as follow :
dsmadmc -se=STAGENT1
Once prompted, enter a valid Tivoli Storage Manager server administrator userid and password. You can then issue the various trace commands to enable, disable, start and end the trace.
Method 2 :
Start a Tivoli Storage Manager administrative command line session with the Tivoli Storage Manager server and use command routing to the storage agent to issue trace commands. For example :
STAGENT1: trace enable LANFREE
STAGENT1: trace begin <filename>
...etc
Because the trace command is prefixed by the storage agent name, the command gets routed to the storage agent. Remember to use a filename format (on the trace begin command) that is recognized by the OS running the agent. If the Tivoli Storage Manager server runs on AIX and the agent is on Windows, then make sure that the tracefile specified includes the right path for the Windows storage agent.
Note :
Due to apars IC56485 and IC56188, make sure that the storage agent is at a minimum level of 5.5.1 before enabling tracing.
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Document Information
Modified date:
17 June 2018
UID
swg21196854