Troubleshooting
Problem
The rc.dsmserv script and inittab entry provided to automatically start the Tivoli Storage Manager server on system start-up may not start dsmserv as expected.
Symptom
The Tivoli Storage Manager Server does not start via the inittab.
Cause
The inittab entry does not specify to correct instance directory.
Environment
Tivoli Storage Manager V6 in UNIX environments using the inittab.
Diagnosing The Problem
If the Tivoli Storage Manager server is not automatically starting after system restart, the following steps can be taken to verify and determine the cause.
The first step is to verify from the operating system perspective that the inittab entry exists and that the rc.dsmserv init script exists.
- [root@server ~]# cat /etc/inittab | grep rc.dsmserv
tsminst1:2:once:/opt/tivoli/tsm/server/bin/rc.dsmserv -u tsminst1 -i /home/tsminst1/tsminst1 -q >/dev/console 2>&1
- [root@server ~]# ls -l /opt/tivoli/tsm/server/bin/rc.dsmserv
-rwxr-xr-x 1 root root 3606 Mar 9 12:24 /opt/tivoli/tsm/server/bin/rc.dsmserv
Once the initial inittab configuration has been verified, the next step is to run the same command that the inittab would be running. Pay special attention to the user that should be running this command:
- [root@server ~]# cat /etc/inittab | grep rc.dsmserv
tsminst1:2:once:/opt/tivoli/tsm/server/bin/rc.dsmserv -u tsminst1 -i /home/tsminst1/tsminst1 -q >/dev/console 2>&1
[tsminst1@server ~]# /opt/tivoli/tsm/server/bin/rc.dsmserv -u tsminst1 -i /home/tsminst1/tsminst1 -q >/dev/console 2>&1
If the Tivoli Storage Manager server does not start after issuing the above command, additional data will need to be collected to determine why the script is not completing. This can be done by simplifying the command so that additional messages are sent to the console:
- [tsminst1@server ~]# /opt/tivoli/tsm/server/bin/rc.dsmserv -u tsminst1 -i /home/tsminst1/tsminst1
ANR7800I DSMSERV generated at 12:11:12 on Mar 9 2009.
Tivoli Storage Manager for Linux/x86_64
Version 6, Release 2, Level 0.0
Licensed Materials - Property of IBM
(C) Copyright IBM Corporation 1990, 2008.
All rights reserved.
U.S. Government Users Restricted Rights - Use, duplication or disclosure
restricted by GSA ADP Schedule Contract with IBM Corporation.
ANR7801I Subsystem process ID is 12091.
ANR0905W Options file /home/tsminst1/tsminst1/dsmserv.opt not found.
ANR7814I Using instance directory /home/tsminst1/tsminst1.
ANR4726I The ICC support module has been loaded.
ANR0990I Server restart-recovery in progress.
ANR0152I Database manager successfully started.
ANR0226S The database ID file could not be found for server startup.
[tsminst1@server ~]#
The above output gives additional clues as to the problem, including the ANR0226S error. In this case, the database ID file could not be found. This means that the instance switch path given does not point to a valid TSM instance directory.
Resolving The Problem
The correct path can be determined by searching for the dsmserv.dbid file on the system.
- [tsminst1@server ~]# find . | grep dsmserv.dbid
/home/tsminst1/dsmserv.dbid
- [root@server ~]# cat /etc/inittab | grep rc.dsmserv
tsminst1:2:once:/opt/tivoli/tsm/server/bin/rc.dsmserv -u tsminst1 -i /home/tsminst1 -q >/dev/console 2>&1
Another test execution should be completed before rebooting to confirm that the new rc.dsmserv command can complete:
- [tsminst1@server ~]# /opt/tivoli/tsm/server/bin/rc.dsmserv -u tsminst1 -i /home/tsminst1/
ANR7800I DSMSERV generated at 12:11:12 on Mar 9 2009.
Tivoli Storage Manager for Linux/x86_64
Version 6, Release 2, Level 0.0
Licensed Materials - Property of IBM
(C) Copyright IBM Corporation 1990, 2008.
All rights reserved.
U.S. Government Users Restricted Rights - Use, duplication or disclosure
restricted by GSA ADP Schedule Contract with IBM Corporation.
ANR7801I Subsystem process ID is 12511.
ANR0900I Processing options file /home/tsminst1/dsmserv.opt.
ANR7814I Using instance directory /home/tsminst1.
ANR4726I The ICC support module has been loaded.
ANR0990I Server restart-recovery in progress.
ANR0152I Database manager successfully started.
ANR1380I The buffer pool monitor switch is enabled.
ANR1635I The server machine GUID, c6.82.1b.fc.1f.09.11.de.85.32.00.14.5e.cc.bb-
.6e, has initialized.
ANR2100I Activity log process has started.
ANR4726I The NAS-NDMP support module has been loaded.
ANR1794W TSM SAN discovery is disabled by options.
ANR0984I Process 1 for EXPIRE INVENTORY (Automatic) started in the BACKGROUND
at 01:47:15 PM.
ANR0811I Inventory client file expiration started as process 1.
ANR2803I License manager started.
ANR8200I TCP/IP Version 4 driver ready for connection with clients on port
1500.
ANR0167I Inventory file expiration process 1 processed for 0 minutes.
ANR0812I Inventory file expiration process 1 completed: processed 0 nodes,
examined 0 objects, deleting 0 backup objects, 0 archive objects, 0 DB backup
volumes, and 0 recovery plan files. 0 objects were retried and 0 errors were
encountered.
ANR0985I Process 1 for EXPIRE INVENTORY (Automatic) running in the BACKGROUND
completed with completion state SUCCESS at 01:47:15 PM.
ANR2560I Schedule manager started.
ANR2828I Server is licensed to support IBM System Storage Archive Manager.
ANR2828I Server is licensed to support Tivoli Storage Manager Basic Edition.
ANR2828I Server is licensed to support Tivoli Storage Manager Extended Edition.
ANR0993I Server initialization complete.
ANR0916I TIVOLI STORAGE MANAGER distributed by Tivoli is now ready for use.
TSM:SERVER1>
If the server starts, as it did in the above example, the rc.dsmserv should also start with the changes made. A reboot will confirm.
Product Synonym
ITSM ADSM TSM IBM SPECTRUM PROTECT
Was this topic helpful?
Document Information
More support for:
Tivoli Storage Manager
Software version:
6.1, 6.2, 6.3
Operating system(s):
AIX, HP-UX, Linux, Solaris
Document number:
624641
Modified date:
17 June 2018
UID
swg21382439