Troubleshooting
Problem
During normal operation the customer experienced many hung BIBUS processes and the following error: DPR-ERR-2077 Failed to forward the request because the associated external process with PID 21862 is unavailable, either because the process is shutting down, or this was an absolute affinity request and the requested process does not exist anymore.
Symptom
DPR-ERR-2077 Failed to forward the request because the associated external process with PID 21862 is unavailable, either because the
process is shutting down, or this was an absolute affinity request and the requested process does not exist anymore.
Cause
Cognos TEMP folder was housed on a NAS drive. This NAS drive was malfunctioning and thus reports would run slow, BIBUS processes would seem to be in a hung state and the logs would show DPR errors with BIBUS not responding.
Environment
Linux server connected to NAS drive.
Diagnosing The Problem
Slow performance.
Hung BIBUS processes.
DPR errors in logs.
Resolving The Problem
Once the malfunctioning NAS drive was resolved, Cognos returned to normal performance.
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21959207