IBM Support

Domino database PIT restore when the database DBIID has changed

Question & Answer


Question

If the Domino DBIID has been changed, is it possible to apply the logs to a restored database?

Cause

This is a limitation for the design of the Domino transaction logging. The transactions stored in the transaction logs are connected with the databases via the DBIID.

Answer

If the DBIID for a Notes Database changes, it is no longer possible to associate transactions with the database. It is necessary to perform a full backup of a database whenever the DBIID is changed.

The same is written in the Data Protection for Domino user's guide:
"Consider the following information when choosing a backup strategy:
When using archival transaction logging, the frequency of archivelog command use depends on the size of your log and the rate of change for logged databases. Perform archival transaction logging several times per day if you generate a large volume of changes at a rapid rate.
When a DBIID for a logged database changes, the database cannot be recovered until another backup of that database is performed. The incremental command detects the changed DBIID. Any changes recorded in the log between the DBIID change and backup are not restored if the original database is lost. The Domino server sends a message to the server console when a DBIID change occurs. It is useful to monitor the server console and perform a backup when a DBIID change occurs."

In addition, the same can be seen on the Domino server console, if the DBIID is changed. For example:
D:\Lotus\Domino>ncompact.exe -B mail\suser.nsf
Restart Analysis (0 MB): 100%
10.09.2015 02:47:19 Recovery Manager: Restart Recovery complete. (0/0 databases needed full/partial recovery)
10.09.2015 02:47:21 Compacting mail\suser.nsf (Some User), -B mail\suser.nsf
Clearing DBIID 66583416 for DB d:\Lotus\Domino\data\mail\suser.nsf
10.09.2015 02:47:22 Recovery Manager: Assigning new DBIID for d:\Lotus\Domino\data\mail\suser.nsf (need new backup for media recovery).
10.09.2015 02:47:22 Compacted mail\suser.nsf, 512K bytes recovered (2%)
10.09.2015 02:47:23 Database compactor process shutdown

Thus, the transaction logs can be applied only up to the date of DBIID change, not after that.

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Product Synonym

TSM

Document Information

More support for:
Tivoli Storage Manager for Mail

Software version:
All Versions

Operating system(s):
AIX, Linux, Windows

Document number:
271603

Modified date:
17 June 2018

UID

swg21970862