IBM Support

The document file C:\..\..\.. is opened by a Microsoft Word user: 'UserName' or 'Unknown'. Do you want to opened read-only?

Troubleshooting


Problem

This technote identifies the cause of the error, "The document file 'document name' is currently opened by a Microsoft® Word user: 'username' or 'Unknown'", which might occur when opening a document that is already opened by another IBM® Rational® RequisitePro® user.

Symptom

Scenario 1

This error occurs when multiple people are accessing the same document. The username that is displayed here is taken from Microsoft® Word settings and not from RequisitePro.



The document file 'document name' is currently opened by a Microsoft Word user: 'username'.
Do you want it opened read-only?

Scenario 2


If a Microsoft Word document has not been closed properly, the WinWord.exe process will continue running in the background. This WinWord.exe process holds onto the document and causes the following error message to appear when opening the document:

The document file C:\..\..\.. is opened by a Microsoft Word user: Unknown. Do you want to opened read-only?

This issue can also occur when current user does not have read/write and modify permissions to the document.

Cause

There may be instances where some users are able to open a document, while other users get the error that the document is currently open by user "unknown", allowing them to only open the document read-only. This is due to a lack of permission for those users on the fileshare where the documents reside. Make sure that any affected users have read/write permissions on the folder or folders the documents are in.

Resolving The Problem

The username that is specified in the error is defined in Microsoft Word under Tools > Options > User Information.


Resolving Scenario 1:
Note: The error message Document opened by Unknown appears if RequisitePro security is enabled for the project.

  1. When Microsoft Word opens a document it writes a temp file in the same directory where the document is located. The name of the temp file begins with "~$filename"
  2. RequisitePro Reads this file to determine who has a document open.
    • You can look at this information if you open the temp file with a text editor such as Notepad.
      Note: The owner information that is written to this file is located in Word's Tools > Options > User Information.
  3. Deleting the temporary file will fix the problem. Check that no one has the document open.
  4. After the temp file is deleted, attempt to reopen the document.

Alternately on Microsoft Windows® 2000 and Microsoft Windows XP:
  1. Select Start > Settings > Control Panel, open Administrative Tools and then open Computer Management
  2. In Computer Management expand the Shared Folders
  3. Select Open Files, which will then display a list of all open files on that specific machine


Beside each file will be the Microsoft windows user name either from the Domain or Workgroup of which user has that specific file open. This identifies the Windows User Name that has the specific document file open.

    On a Microsoft Windows NT®
    1. Select Start > Settings > Control Panel and open Server
    2. Select the In Use icon from the Server menu
    3. The In Use will then display a list of all open files on that specific machine.

    Beside each open resource, a Domain or Workgroup Windows username will be listed. This will identify the user that has the Document open.


Resolving Scenario 2:
Use the following instructions to resolve the read-only issue:
  1. Shut down RequisitePro.
  2. Open Windows Task Manager and make sure that the following processes are stopped:
    • requisitepro.exe
    • winword.exe
  3. Navigate to the folder that contains the document you are trying to open.
    Note: If the document is in a shared directory and is being referenced with a UNC path the Users Permissions on the Security and Sharing Tabs need to be validated. The user, or user's group needs read, write and modify permissions on both tabs.
  4. Delete any document file that starts with ~$
    Note: The ~$ is a hidden file you will have to enable the display of in Microsoft Windows® Explorer in the Tools > Folder Options > View tab.
  5. Restart RequisitePro and try opening the document again.


Note: In some scenarios, restarting the client machine and even restarting the server might be necessary.
[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Document Properties","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8;7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

21229

Document Information

More support for:
Rational RequisitePro

Software version:
2003.06.14, 2003.06.15, 2003.06.16, 7.0, 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.0.5, 7.0.0.6, 7.0.0.7, 7.0.0.8, 7.0.0.9, 7.0.1, 7.0.1.1, 7.0.1.2, 7.0.1.3, 7.0.1.4, 7.0.1.5, 7.0.1.6, 7.0.1.7, 7.0.1.8, 7.1, 7.1.0.1, 7.1.0.2, 7.1.1, 7.1.1.1

Operating system(s):
Windows

Document number:
88409

Modified date:
16 June 2018

UID

swg21252791

Manage My Notification Subscriptions