IBM Support

Document and Attachment upload failure from Anywhere Application

Question & Answer


Question

When attempting to upload files and images from the mobile application to a work task in the TRIRIGA application, no content appears. There are no error messages displayed in the mobile application indicating that any problem has occurred. This was noted after upgrading the application and platform from 10.3.x/3.3.x to 10.4.x/3.4.2.

Cause

Application builds prior to 10.4 lack a folder called TRIRIGAAnywhere in the document manager file structure. Essentially, there is no location for Anywhere content to be uploaded to, and so a user attempting to add content from the Anywhere mobile application will be unable to. No error is displayed on the mobile application, but there will be an error displayed in the Mobile First logs.

Answer

The corrective action is actually quite simple. Just add a folder under the ROOT folder called TRIRIGAAnywhere and add your Anywhere/Mobile First user groups to that folder's security. That will resolve the issue and allow for attachments to be uploaded.

NOTE: The Folder/Directory name is case sensitive and must match exactly - TRIRIGAAnywhere

Application builds that begin with 10.4.x will have this folder, and other possible root causes need to be investigated should there be an issue with attachments.

[{"Product":{"code":"SSVNWU","label":"IBM TRIRIGA Anywhere"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.4.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21988779