Troubleshooting
Problem
While launching the Discovery Management Console the application is blocked from starting because of an expired certificate window message. This may occur on TADDM 7.3 and 7.2.2 environment as well.
Cause
The following JAVA url explains the root cause:
specifically into the related section:
Environment
TADDM 7.3 and 7.2.2 env
Diagnosing The Problem
While launching the Discovery Management Console the application is blocked from starting because of an expired certificate window message similar to the following :
Moreover, it does not give apparently any option to configure java security to ignore checking certificate even if it may be against a customer organization's security policy and may not be allowed.
So that the issue prevents customer from being able to launch the application console and to get further confirmation on the specific issue, when trying to check guiclient-msgs.jar, the system shows validity till 04/17/2016 (below screenshot):
This may occur on both TADDM 7.3 (FP2 and less) and 7.2.2 environment (FP4 and less).
Resolving The Problem
The certificate used for signing TADDM jars has expired on April, 17th.
TADDM dev team is aware of this revocation date, and in fact there are fixpacks for each releases (FP5 for 7.2.2 and FP3 for 7.3) already containing jars signed with new certificate.
What should the customer having an older fixpack do ?
There are three options for solution:
1 - upgrade to the latest fixpack of current TADDM customer release;
- or
https://java.com/en/download/help/revocation_options.xml
- or
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Document Information
Modified date:
17 June 2018
UID
swg21982390