IBM Support

Disabling Single Sign On (SSO) Causes the Login Page to Display 'OP-00048: The session has expired'

Troubleshooting


Problem

An administrator disabled the Single Sign On (SSO) integration at the proxy server / custom DNS, now the OpenPages login screen display an 'OP-00048: The session has expired' message.

Symptom

After disabling Single Sign On (SSO), the custom SSO redirect URL displays the OpenPages login page along with the message: OP-00048: The session has expired.

Cause

The proxy server is routing to home.do page.

Resolving The Problem

When SSO is enabled, the URL is supposed to redirect to the home.do page. For example, http://myopenpages.mycompany.com:7009/openpages/home.do. When end users are authenticated through a SSO solution, end users are typically routed to homepage with a valid session token.

When SSO is disabled and end users continue to use the same redirected URL, the end users will no longer have a valid, authenticated session token. Therefore they will get an 'OP-00048: The session has expired.'

If SSO is going to be disabled, the redirection should go to: /openpages or /openpages/log.on.do instead. For example: http://myopenpages.mycompany.com:7009/openpages or http://myopenpages.mycompany.com:7009/openpages/log.on.do.

[{"Product":{"code":"SSFUEU","label":"IBM OpenPages with Watson"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2;6.1.0.1;6.1;6.0.1.5;6.0.1.4;6.0.1.3;6.0.1.2;6.0.1.1;6.0.1;6.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21628897