IBM Support

DFHTM1781 non-system user tasks not terminated and CICS immediate shutdown hangs

Troubleshooting


Problem

Your CICS region is hanging indefinitely after you enter CEMT PER SHUT IMMEDIATE. The last message CICS returns is DFHTM1781 stating CICS shutdown can not complete because some non-system user tasks have not terminated. The region comes down successfully when you enter CEMT PER SHUT.

Symptom

In this case, the region also comes down when you enter OMEG SHUT to bring down OMEGAMON prior to doing an immediate shutdown.

Cause

CICS does not run the shutdown (PLTSD) programs when you do an immediate shutdown. Therefore, the OMEGAMON shutdown program does not run. CICS is also unable to run the shutdown assist transaction CESD because RACF authorization is not defined for CESD.

Resolving The Problem

Add transaction CESD as a category 2 transaction to the RACF security system. Afterwards, the shutdown transaction will have the authority to purge non-system transactions, including the OMEGAMON transaction.

Note: CICS generates message DFHTM1703 when you do an immediate shutdown. You can find this message in your CICS log.

Related Information

[{"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Shutdown","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"4.2;4.1;3.2;3.1","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

CICS/TS CICS TS CICS Transaction Server

Document Information

Modified date:
15 June 2018

UID

swg21144620