IBM Support

Detailed System Requirements for the Data Privacy Components of IBM InfoSphere Optim v9.1

Detailed System Requirements


Abstract

The system requirements for the Data Privacy Components of IBM® InfoSphere® Optim™ v9.1 are compiled in this document.

Content

The data privacy components provide support for data masking in addition to the data masking abilities supported through the use of column maps. There are three data privacy components:

  1. A data privacy application that provides a graphical user interface to mask data in CSV and XML files and a command line interface to mask data in CSV and XML files, as well as data originating in a Hadoop environment.
  2. A stand-alone API (Optim data privacy providers or ODPP) that provides a flexible and extensible means of accessing pre-defined and user-developed data masking services with no need to install the Optim Test Data Management Solution. Functions in this API can be called from user-developed applications as well as from column map exits and Lua scripts for column map procedures, providing consistent, repeatable data masking results regardless of the application or platform. Note that column map exit and Lua support for these functions is an integral part of the Data Privacy option for the Test Data Management solution; you need not install the API separately to use this support.
  3. User defined functions (UDFs) for databases can be included in SQL scripts or statements to dynamically mask data within the framework of the DBMS server so that the data is masked in place without leaving the database.

Minimum hardware requirements

Minimum hardware requirements for using any data privacy component are:

AIX® HP-UX or HP-Itanium Linux Microsoft Windows Solaris Yes,

IBM Power5 or IBM Blade (Dual or Quad Core)

PA-RISC or HP BladeSystem (Dual or Quad Core)

Intel Xeon or AMD Opteron, (Dual Core or Quad Core)

Intel Pentium

Sun SPARC Enterprise or Sun Blade (Dual or Quad Core)

Any z/OS operating system that supports z/Linux

1 – 2 Cores

1 – 2 Cores

1 – 2 Cores

1 – 2 Cores

1 – 2 Cores

1 – 2 Cores

2.0 GHz

2.0 GHz

2.0 GHz

1.5 GHz

2.0 GHz

2.0 GHz

1 GB RAM

1 GB RAM

1 GB RAM

If downloading an electronic version,
2 GB of temporary disk space is needed. A DVD drive is required if installing from optical disk. In addition,
2 GB of disk space is required for component package installation. IBM Installation Manager, if not previously installed, requires at least 100MB of disk space.

1 GB RAM

1 GB RAM

Supported operating systems

The Data Privacy Application is only supported on Windows and Red Hat Linux platforms in the following list.

As of v9.1.0.6 (9.1.0 Fix Pack 6), support for HP-UX Itanium and Red Hat Enterprise Linux 3 has been discontinued.

Supported operating systems for the API are:

AIX® HP-UX or HP-Itanium Linux Microsoft Windows Solaris z/Linux z/OS

AIX 5.3 (in 32-bit or 64-bit mode)

AIX 6.1 (in 32-bit or 64-bit mode)

HP-UX 11.11

HP-UX 11i v2

HP-UX 11 iv3

HP-UX 11iv2 on Itanium

HP-UX 11iv3 on Itanium

Red Hat Enterprise Linux 3.0 AS/ES x86-32

Red Hat Enterprise Linux 3.0 AS/ES x86-64

Red Hat Enterprise Linux 4.4 AS/ES x86-32

Red Hat Enterprise Linux 4.4 AS/ES x86-64

Red Hat Enterprise Linux 5.0 AS/ES x86-32

Red Hat Enterprise Linux 5.0 AS/ES x86-64

Red Hat Enterprise Linux 5.4 AS/ES x86-32

Red Hat Enterprise Linux 5.4 AS/ES x86-64

SUSE Linux Enterprise Server 9 (in 32-bit or 64-bit mode)

SUSE Linux Enterprise Server 10 (in 32-bit or 64-bit mode)

Windows Server 2003 Enterprise Edition x86-32 (SP1)

Windows Server 2003 Standard Edition x86-32 (SP1)

Windows Server 2003 Standard Edition x64 (in 32-bit mode)

Windows Server 2003 R2 Enterprise Edition x86-32

Windows Server 2003 R2 Standard Edition x86-32

Windows XP Professional x64 (SP2) (in 32-bit mode)

Windows XP Professional x86-32 (SP2)

Windows Vista (Business, Enterprise, Ultimate) x86-32

Windows Vista (Business, Enterprise, Ultimate) x86-64 (in 32-bit mode)

Windows Server 2008 Enterprise Edition x86-64 (in 32-bit mode)

Windows 7 x86-32

Windows 7 x86-64 (in 32-bit mode)

Oracle Solaris 8 (in 32-bit or 64-bit mode)

Oracle Solaris 9 (in 32-bit or 64-bit mode)

Oracle Solaris 10 (in 32-bit or 64-bit mode)

Red Hat (in 31-bit or 64-bit mode)

SUSE (in 31-bit or 64-bit mode)

z/OS-USS v1.12 or above (in 31-bit mode)

Libraries and compilers

Libraries are built on the following operating systems with the indicated compilers:

  • AIX 5.3 (in 32-bit or 64-bit mode)
    Compiler: IBM XL C/C++ Enterprise Edition for AIX, V9.0
  • HP-UX (in 32-bit or 64-bit mode)
    Compiler:HP aC++ A.03.85
  • HPIA (in 32-bit or 64-bit mode)
    Compiler:HP C/aC++ B3910B A.06.15 [May 16 2007]
    Support for HPIA (HP-UX Itanium) has been discontinued as of v9.1.0.6 (9.1.0 Fix Pack 6)
  • Red Hat Enterprise Linux 3.0 AS/ES x86-64
    Compiler: gcc 3.4.3
    Support for RHEL 3 has been discontinued as of v9.1.0.6 (9.1.0 Fix Pack 6)
  • Red Hat Enterprise Linux 4.0 AS/ES x86-64
    Compiler: gcc 4.1.2
  • SUSE Linux Enterprise Server 9 (running in 32-bit or 64-bit mode)
    Compiler: gcc 3.4.3
  • Oracle Solaris 8 (running in 32-bit or 64-bit mode)
    Compiler: Sun C 5.8 2005/10/13
  • Microsoft Windows Server 2003 R2 Standard Edition x64 (running in 32-bit mode)
    Compiler: Visual Studio 2008 Professional, Version 9.0.30729.1 SP, Microsoft .NET Framework Version 3.5 SP1
  • z/Linux
    • Red Hat (running in 31-bit or 64-bit mode)
      Compiler: gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)
    • SUSE Linux Enterprise Server 10 SP3 (s390x) (running in 31-bit or 64-bit mode)
      Compiler: gcc version 4.1.2

User defined functions

User defined functions are supported for the following databases:

  • DB2 for z/OS v9.1
  • DB2 for z/OS v10.1
  • Netezza v6.0.8
  • Netezza v7.0
  • Oracle v10.2 on supported Solaris 64-bit and Windows 32-bit platforms
  • Oracle v11.2 on supported AIX 64-bit, Red Hat Linux 64-bit, Solaris 64-bit, and Windows 32-bit platforms
  • Teradata v13
  • Teradata v13.10
  • Teradata v14

Supported Character Sets

Unicode databases in all supported database management systems are supported. See supported character sets.

[{"Product":{"code":"SSMLQ4","label":"IBM InfoSphere Optim Test Data Management Solution"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Data Privacy","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"9.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
08 July 2021

UID

swg27036212