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Delete Volume fails with ANR0126W

Troubleshooting


Problem

Delete Volume fails with warning message: ANR0126W DELETE VOLUME: Volume Vol_name contains retention protected data and can not be deleted.

Symptom

Tivoli Storage Manager Delete Volume fails due to a warning message ANR0126W Contains Retention Protected Data

Cause

Tivoli Storage Manager Backup/Archive Client placed a Hold on stored object

Diagnosing The Problem

Tivoli Storage Manager server Actlog reports message:

ANR0126W DELETE VOLUME: Volume Vol_name
contains retention protected data and
can not be deleted.(SESSION: xxx, PROCESS: yyy)

Explanation: The specified volume cannot be deleted because it contains one
or more objects that must be retained because of one of the following:

* Archive retention protection is enabled and the object's retention
period has not elapsed.

* The object is part of a deletion hold.


If this is not an expected warning message, verify if Archive Retention Protection is enabled:

From a Tivoli Storage Manager Admin command line client, do:

Q STATUS

Example output:

Server Name: TEST
Server host name or IP address: x.x.x.x
Server TCP/IP port number: 1500
...
Context Messaging: Off
Server-free Status: On
Server-free Batch Size: 200
Table of Contents (TOC) Load Retention: 120 Minute(s)
Machine Globally Unique ID:
Archive Retention Protection: Off
Encryption Strength: AES

If "Archive Retention Protection" is set to "Off", as in this example, then the Tivoli Storage Manager Client or Tivoli Storage Manager API client has placed a hold on this object.

To find the object and node that has the hold, do the following command on the volume name listed in message ANR0126W:

Q CONtent Vol_Name

This will list the Node Names and files stored on the volume.

Go to the Client and verify if the above objects have the hold set on each object:

Example:
dsmc q archive -detail "C:\OFFICESCAN8-\OSCE_8.0_WIN_EN_PATCH2.EXE"

26,209,828 B 03/25/2008 17:14:53
\\us1ntmgt02\c$\officescan8-\OSCE_8.0_WIN_EN_patch2.exe 03/25/2009
Archive Date: 03/25/2008 test RetInit:STARTED ObjHeld:YES
Modified: 03/05/2008 11:26:47 Created: 03/25/2008 13:16:37

This Backup/Archive client has set a hold "ObjHeld:YES" on this file, preventing any deletion of the object from Tivoli Storage Manager Server storage.

Resolving The Problem

Run the following dsmc client command to remove this hold:

SET Event -TYPE=Release <filespec>

Ex:
dsmc SET Event -TYPE=Release "C:\OFFICESCAN8-\OSCE_8.0_WIN_EN_PATCH2.EXE"

Once this is done on all objects that had the ObjHeld set to yes (now set to No), you will be able to delete the volume from Tivoli Storage Manager Server storage.

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Document Information

Modified date:
17 June 2018

UID

swg21377012