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Delete filespace command completes successfully but filespace not removed

Troubleshooting


Problem

Filespace for a given nodename not removed even though the command completes successfully.

Symptom

Messages similar to the following will be logged in the server activity log:

ANR2017I Administrator admin issued command: DELETE FILESPACE {nodename} {filespace} (SESSION: 1234)
ANR0984I Process 567 for DELETE FILESPACE started in the BACKGROUND at 12:20:07. (SESSION: 1234, PROCESS: 567)
ANR0800I DELETE FILESPACE {filespace} (fsId=2) for node {nodename} started as process 567. (SESSION: 1234, PROCESS: 527)
ANR0802I DELETE FILESPACE {filespace} (fsId=2) (backup/archive data) for node {nodename} started. (SESSION: 1234, PROCESS: 567)
ANR0806I DELETE FILESPACE {filespace} (fsId=2) complete for node {nodename}: 0 objects deleted. (SESSION: 1234, PROCESS: 567)
ANR0985I Process 567 for DELETE FILESPACE running in the BACKGROUND completed with completion state SUCCESS at 12:20:07. (SESSION: 1234, PROCESS: 567)

Cause

Filespace name is an HSM Managed filesystem.

Diagnosing The Problem

Run the following commands to get more details about the filespace:

query file {nodename}
query occ {nodename}

Resolving The Problem

When running the delete filespace command without the TYPE parameter, the default is TYPE=ANY, which deletes only backed-up versions of files and archived copies of files. In the case where HSM data is stored in the file space, it is necessary to specify TYPE=SPACEMANAGED to delete the HSM data. For example :

delete filespace mynode myfe TYPE=SPACEMANAGED

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21672065