IBM Support

Delay in Oracle crosscheck processing

Question & Answer


Question

Why does an Oracle Crosscheck take longer to run using the 6.3 or higher API then with lower levels of the API ?

Cause

CITSCAN A new function introduced in the 7.1 API CITSCAN causes a 1 second delay on each session init call.

Answer

The CITSCAN was intended to run only a single time, and not to run on subsequent session init calls in the same client invocation. However in 7.1 the scan is preformed and 1 second delay is caused for EVERY session init call (this is fixed by APAR IT05514).

For operations that open many individual sessions, such as an Oracle Crosscheck can experience significantly longer run times, for example a Crosscheck that opens 1200 session would run 20 min longer then the same Crosscheck using a 6.2 or lower API.

The TESTFLAGS CITSCANDISABLE can be set in the DSM.OPT file used by the problem operation to stop all but the first run of the scan and have the affected operation run in a shorter time.

[{"Product":{"code":"SSTFZR","label":"Tivoli Storage Manager for Databases"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for Oracle","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.3;6.3.1;6.4;6.4.1;7.1;7.1.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21974372