IBM Support

DDM20230E ERROR: The Cache server [Server Name] version cannot be verified. Windows error [0x80040154]: Class not registered

Question & Answer


Question

The IBM® DB2® Document Manager remote client displays the following error when it tries to connect to the DB2 Document Manager server: DDM20230E ERROR: The Cache server [Server Name] version cannot be verified. Windows error [0x80040154]: Class not registered

Cause

This error might be caused by a corrupt DLL file.

Answer

Important: This technical support document is specific to the error [0c80040154]: Class not Registered. See the Related links section for other possible causes for DDM20230E error messages.

On the client workstation that displays the error, go to Start -> Control Panel -> Add or Remove Programs -> IBM DB2 Document Manager and choose Change, On the Program Maintenance screen, choose Repair option.

Test the client connection. If it still fails with the same error, use Add or Remove Programs to uninstall the client. Reinstall the client using the method supported by your company.

If the problem persists, then contact IBM Software Support for assistance.

[{"Product":{"code":"SSDSNY","label":"Document Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Desktop","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;8.3.1;8.3.2;8.3.3;8.3.4;8.3.5;8.3.6;8.3.7;8.3.8;8.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21304180