IBM Support

DBI1306N The instance profile is not defined

Troubleshooting


Problem

The Tivoli Storage Manager Server instance fails to start with the DBI1306N error after an upgrade.

Cause

Tivoli Storage Manager Server instance got deleted or uncataloged.

Diagnosing The Problem

The following commands will fail to run:

db2 connect to tsmdb1
db2 list db directory

Resolving The Problem

The Tivoli Storage Manager Server instance needs to be recreated/cataloged. Use the steps below.

  1. Create the Server instance :http://www-01.ibm.com/support/knowledgecenter/SSGSG7_7.1.0/com.ibm.itsm.srv.install.doc/t_srv_install_createdbinst-windows.html
  2. Catalog the TSMDB1 database:
    db2 catalog db tsmdb1
  3. Try to start the Tivoli Storage Manager Server. If the following error is logged :
    -5035:SQLSTATE 55001: The database must be upgraded.
    Please run the following command :
    db2 upgrade db tsmdb1
    Note: It may be necessary to start the DB2 instance with the 'db2start' command first.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21692405