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DB2START fails with SQL1042C error and ENOMSG (35) reported in the db2diag.log

Question & Answer


Question

This technote explains a problem that might happen during instance initialization. DB2START suddenly stops working and the db2diag.log reports a ENOMSG error

Cause

When you try to start the DB2 instance the following error is returned:

  • /:> db2start                                                
    11/15/2006 14:43:32     0   0   SQL1042C  An unexpected system error occurred.                                                               SQL1032N  No start database manager command was issued.  SQLSTATE=57019

The db2diag.log reports the following messages:
  • 2006-11-15-14.17.48.586150-300 E676575A1455 LEVEL: Severe (OS)
    PID : 999458 TID : 1 PROC : db2star2
    INSTANCE: db2inst1 NODE : 000
    FUNCTION: DB2 UDB, oper system services, sqloWaitIPCWaitPost, probe:100
    MESSAGE : ZRC=0x83000023=-2097151965
    CALLED : OS, -, msgrcv
    OSERR : ENOMSG (35) "The specified message type does not exist on a message queue."
    DATA #1 : timeout value, 4 bytes
    0
    DATA #2 : String, 193 bytes
    {
    pc = 0x0
    cs = {
    lock = { 0x10000000 [ locked ] }
    identity = sqlo_waitpost::cs (6)
    }

    state = 0x2
    guard = initialized
    flags = 0x2
    numWaiters = 1
    }
    DATA #3 : ipc waitpost, PD_TYPE_SQLO_IPCWAITPOST, 28 bytes
    0x07800000000400B8 : 0000 0000 1000 0000 0006 0000 0000 0002 ................
    0x07800000000400C8 : 0000 ABFE 0002 0000 0000 0001 ............
    DATA #4 : system V message queue identifier., PD_TYPE_SYSV_QUEUE_ID, 4 bytes
    0x0B000001
    DATA #5 : Bitmask, 8 bytes
    0x0000000000000000
    CALLSTCK:
    [0] 0x09000000110741C0 pdLogSysRC@glue61 + 0x170
    [1] 0x09000000122702C8 sqloWaitIPCWaitPost + 0xFFFFFFFFFFFFFFDC
    [2] 0x0000000100005060 DB2StartMain + 0x2ED4
    [3] 0x0000000100007D58 main + 0x10
    [4] 0x00000001000002D0 __start + 0x90
    [5] 0x0000000000000000 ?unknown + 0x0
    [6] 0x0000000000000000 ?unknown + 0x0
    [7] 0x0000000000000000 ?unknown + 0x0
    [8] 0x0000000000000000 ?unknown + 0x0
    [9] 0x0000000000000000 ?unknown + 0x0

    2006-11-15-14.17.48.840711-300 I678031A378 LEVEL: Error
    PID : 999458 TID : 1 PROC : db2star2
    INSTANCE: db2inst1 NODE : 000
    FUNCTION: DB2 UDB, base sys utilities, DB2StartMain, probe:660
    MESSAGE : db2sysc exited prematurely. sqlcode :
    DATA #1 : Hexdump, 4 bytes
    0x0FFFFFFFFFFFC9CC : 8300 0023 ...#

    2006-11-15-14.17.48.841027-300 I678410A353 LEVEL: Error
    PID : 999458 TID : 1 PROC : db2star2
    INSTANCE:  db2inst1 NODE : 000
    FUNCTION: DB2 UDB, base sys utilities, DB2StartMain, probe:670
    MESSAGE : db2syscPID :
    DATA #1 : Hexdump, 4 bytes
    0x0FFFFFFFFFFFC9E4 : 000F 503E ..P>

The problem is that you are using a security software that might be killing the DB2 main process, db2sysc when it tries to initialize. 

Answer

Configure the security software to accept DB2 processes.

It is possible the files profiles.reg and global.reg could be corrupted in
some way. Please do the following after bringing down all DB2 processes:

cd /var/db2/<version_id>
mv profiles.reg profiles.reg.bak

cd /var/db2
mv global.reg global.reg.bak

This way you will have backups of these files if needed for any reason.
DB2 will recreate these files when needed.

Retry db2start.

If the issue is not resolved, please engage DB2 support

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Database Objects\/Config - Instance","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.7;9.5;9.1","Edition":"Enterprise Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
08 December 2022

UID

swg21250240