IBM Support

Db2 Knowledge Center updates for Db2 Version 11.5

Question & Answer


Question

Are there any further updates to the Db2 Version 11.5 Knowledge Center pages?

Answer

Updates are listed below.
The following new adapters have been added:
The Db2 pureScale Feature is supported on POWER9® compatible rack mounted server that supports one of the Ethernet RoCE adapters listed:
  • PCIe3 2-port 10 Gb NIC & RoCE SR/Cu adapter with feature code EC2U, EC2T
New notes under Table 1:
Table 1. "Software requirements" now includes AIX 7.2 TL05 SP1 with APAR IJ30808
Configuring the network settings of hosts in a Db2 pureScale environment on a RoCE network with IP support (AIX)
Link: https://www.ibm.com/docs/en/db2/11.5?topic=crna-configuring-network-settings-hosts-roce-network-ip-support-aix
This topic is up to date.
Installation prerequisites for Db2 pureScale Feature (Power Linux)
New notes for Table 1 - "Software requirements":
  • 4. When using RHEL 8.1, the Db2 level must be 11.5.5.0 or higher.  RHEL 8.1 currently supports TCP only (no RDMA), and may only be able to run on POWER8® systems (no POWER9® support).
Table 1. "Software requirements" now includes:
  • RHEL 9.2.  The required packages and OpenFabrics Enterprise Distribution (OFED) package  for this operating system level are the same as RHEL 8.8.
The following new adapters have been added:
The Db2 pureScale Feature is supported on POWER10® compatible rack mounted server that supports one of the Ethernet RoCE adapters listed:
  • PCIe3 2-port 10 Gb NIC & RoCE SR/Cu adapter with feature code EC2U, EC2T
 
New notes under Table 1:
  • When using EC2U/EC2T RoCE cards on POWER10® systems, one must use at least Db2 11.5.9.0 with at least RHEL 9.2
Installation prerequisites for Db2 pureScale Feature (Intel Linux)
Link: https://www.ibm.com/support/knowledgecenter/SSEPGG_11.5.0/com.ibm.db2.luw.qb.server.doc/doc/r0057441.html
New notes under Table 1:
  • When using a Mellanox ConnectX-6 card for RoCE on SLES, one must use SLES 15 SP4 or higher, with Db2 11.5.8.0 or higher.
The following note now has expanded support:
The Db2 pureScale Feature (including a geographically dispersed Db2 pureScale cluster, or GDPC) is supported on any x64 Intel compatible rack-mounted server that supports these 2-port Ethernet RoCE or Infiniband adapters in a PCI slot:
  • Mellanox ConnectX-6 generation card that supports RDMA over converged Ethernet (RoCE) (RHEL and SLES)
IBM validated these adapters, which are configurable options on Lenovo x-Series servers:
  • Mellanox ConnectX-6 Lx 10/25GbE SFP28 2-port PCIe Ethernet Adapter (02YG184)
Installation prerequisites for Db2 pureScale Feature (Linux on IBM Z)
Table 1. "Linux on IBM z16 software requirements" now includes:
  • Red Hat® Enterprise Linux (RHEL) 9.2 with 11.5.9.0.  The required packages and OpenFabrics Enterprise Distribution (OFED) package  for this operating system level are the same as RHEL 8.8 with 11.5.9.0.

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"11.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
03 July 2024

UID

ibm10876712