IBM Support

DB2 database restore/upgrade may fail with SQL0440N on routine "ADMIN_GET_TEMP_TABLES" due to timezone difference

Troubleshooting


Problem

When doing a restore/upgrade of a database from an earlier release of DB2, the following error may occur: SQL0440N No authorized routine named "ADMIN_GET_TEMP_TABLES" of type "FUNCTION" having compatible arguments was found. SQLSTATE=42884

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Install\/Migrate\/Upgrade - Instance","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.1;10.5;9.5;9.7","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Log InLog in to view more of this document

This document has the abstract of a technical article that is available to authorized users once you have logged on. Please use Log in button above to access the full document. After log in, if you do not have the right authorization for this document, there will be instructions on what to do next.

Document Information

Modified date:
19 June 2026

UID

swg21689249