Troubleshooting
Problem
SQL2025N / RC 29 failure when performing a DB2 API backup to IBM Spectrum Protect Server
Symptom
The message below will be reported on the client in the screen output (or log output, if redirecting the output of the command to a file, as part of a scheduled script) of the 'db2 backup db...' command
SQL2025N An I/O error "29" occurred on media "TSM".
Cause
The Return Code 29 is being reported by the IBM Spectrum Protect API, and this RC indicates that the IBM Spectrum Protect Server is out of storage space
Diagnosing The Problem
Review the Tivoli Storage Manager Server activity log for entries similar to the following:
ANR0522W Transaction failed for session ##### for node DB2_NODENAME (DB2/AIX64) - no space available in storage pool STGPOOL_NAME and all successor pools.
Resolving The Problem
If backing up to a sequential storage pool (tape or file volumes), ensure that the storage pool:
- is set to read/write
- that the MAXSCRATCH is set high enough to allow additional scratch volumes to be defined
- there are plenty of scratch volumes available for the backup.
If backing up to disk or file volumes,
- ensure that the target location, where the volumes reside, have available space.
If the backup is being stored in a random (disk) storage pool, this will first allocate the space for the DB2 database and then begin to store the data to this pre-allocated space. In some cases there may be more data backed up than the estimate used for the allocation. To avoid this type of scenario ensure you have extra space available in the storage pool and,
- consider defining additional volumes to the diskpool
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21980265