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Database restore fails with, 'DB2 sqlcode: -2033. DB2 sqlerrmc: -50'

Troubleshooting


Problem

Database restore fails with errors: ANR2969E Database restore terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: -50

Symptom

A trace of the API using the 'service' traceflag may show successful connections open from the API client to the server, but later connections fail with a connection time out error:

psTcpConnect(): Attempt socket 10 (IPv4) connection -> rc=-1, errno=78


The failure is intermittent, so that sometimes the connection failure happens early, but on subsequent attempts the failure happens much later. In cases where the restore runs for a longer period without failing, the performance of the restore will be significantly diminished.

Cause

The dsmserv port is being flooded with connection requests from backup clients. This can cause packets to overflow the IP input queue on the server, causing other connections to fail with the time out error.

Environment

A large server environment with hundreds of client nodes.

Diagnosing The Problem

Check network connections to the IBM Spectrum Protect server using the 'netstat -an' command. A great number of connections being opened but not established to the dsmserv listening port may indicate this problem.

You can also run 'netstat -s' on AIX and check the 'ipintrq' value, which, if greater than 0, indicates that packets have overflowed the IP input queue.

Resolving The Problem

You can resolve this problem by

1: Increasing the IP input queue in the IP stack of the server. Methods for doing this will vary by operating system, so discuss this option with the system administrators.

2: Alternatively, you can configure the dsmserv to listen on a different port. This will prevent packets destined for the default dsmserv tcpport from flooding the queue. Edit the server option file dsmserv.opt and change TCPPORT to a different port number, making sure it is not in use by another program. Then edit the API's option file and change the TCPPORT value so it matches the value in the dsmserv.opt.

After the database has been successfully restored, the TCPPORT options should be set back to the original value.

3: Another option for Spectrum Protect 7.1 and higher versions is to configure the database restore to use shared memory. Refer to step #5 in the Spectrum Protect Knowledge Center document linked below:


Configure the server to back up the database by using shared memory

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Product Synonym

tsm adsm TIVOLI STORAGE MANAGER IBM SPECTRUM PROTECT

Document Information

More support for:
Tivoli Storage Manager

Software version:
6.3, 7.1

Operating system(s):
AIX

Document number:
544765

Modified date:
17 June 2018

UID

swg21978826