About cookies on this site Our websites require some cookies to function properly (required). In addition, other cookies may be used with your consent to analyze site usage, improve the user experience and for advertising. For more information, please review your options. By visiting our website, you agree to our processing of information as described in IBM’sprivacy statement. To provide a smooth navigation, your cookie preferences will be shared across the IBM web domains listed here.
Troubleshooting
Problem
When you attempt to expand one Resource pool in the Resource Management view of IBM Rational Portfolio Manager, this results in a "Database error. Please contact your System Administrator" error message being returned by the Rational Portfolio Manager client.
Symptom
The Rational Portfolio Manager client pops up the following database error:

In the database alltraces.log file, the following error message can be found:
ENTER : SP_POOL_VIEW : 2010-01-12-15.36.59.549532
// 2010-01-12-15.36.59.549532 : call SP_POOL_VIEW()
SQL_ERROR[-180]: views_pool.sqC(12996): PMOR3!SP_POOL_VIEW : 2010-01-12-15.36.59.549368 : SQL0180N The syntax of the string representation of a datetime value is incorrect. SQLSTATE=22007
Cause
This problem is caused by a resource that is assigned to one project with effort having an assignment record in the PROJECT_ASSIGNMENTS table, but no corresponding assignment record in the TASK_ASSIGNMENTS table. The data is not consistent in these two tables and this results in the database error.
Diagnosing The Problem
The diagnosis of this problem will have to be performed by a Technical Support Engineer from the Rational Portfolio Manager Client Support team.
Resolving The Problem
Please contact a TSE from the Rational Portfolio Manager Client Support team in order to help you resolve this issue. The TSE will assist in determining which resource assignment is causing the problem. Once this resource has been identified, execute the following steps to resolve the problem:
- Highlight the project in the Work Management view
- Navigate to the Staffing View
- Select the Project Resources tab
- On this tab, select the resource that was identified as being the cause of this problem
- Delete the resource from the project
- Re-assign the resource to the project
This will resolve the issue and will prevent the error message from occurring.
[{"Product":{"code":"SSRR2G","label":"Rational Portfolio Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Resource Management","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF033","label":"Windows"}],"Version":"7.1.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
More support for:
Rational Portfolio Manager
Software version:
7.1.1.2
Operating system(s):
AIX, Windows
Document number:
398975
Modified date:
16 June 2018
UID
swg21419008