IBM Support

Data source cannot be found for query items in IBM Cognos Framework Manager

Troubleshooting


Problem

When testing the packaged query items in IBM Cognos Framework manager or when running the reports from the IBM Rational Insight server, the data source cannot be located in the content store.

Symptom

The full error message is as follows:

Error : QE-DEF-0288 Unable to find the data source <DataSourceName> in the content store.


The error occurs when sample testing a query subject (table) in Cognos Framework Manager.

Steps to reproduce:
  1. In the Project Viewer of Framework Manager, expand Data Sources

  2. Right-click the data source and click Test

Cause

Missing data source definition at the Rational Insight server.

Environment

IBM Cognos Framework Manager 8.4.27.28

Resolving The Problem

Procedure:

  1. Open the Cognos Web application

  2. Open the Cognos administration page (Launch > IBM Cognos Administration)

  3. Click Configuration

  4. Click New Data Source

  5. Specify the name for the data source

    Note:
    The name should be the same as the one shown in the error message

  6. Click Next

  7. Select the type as ODBC

  8. Click Next

  9. Specify the value for the ODBC Data Source field

    This value must be the System DSN that uses the Rational Insight XDC Driver and points to the hpqc.xdc file

  10. If you want to, specify the values for the timeout and Signon fields

  11. Click Finish

[{"Product":{"code":"SSRL5J","label":"Rational Insight"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"HPQC Adaptor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21395673