IBM Support

Data Protection for SQL query of fileinfo fails with ACO015E

Troubleshooting


Problem

Tdpsqlc q tsm /fileinfo /all fails with ACO0151E Errors occurred while processing the request

Cause

To diagnose whether a redirected restore of inactive backups taken with Data Protection client version 5.5.4 or 5.5.5 are hitting APARs IC71334 or IC75456, it is necessary to query the Tivoli Storage Manager Server for the file information for inactive backups.

Diagnosing The Problem

The following queries can be run to check if the meta data for the backups is stored successfully or whether the data is affected by the APARs:

  • Running tdpsqlc q tsm dbname full /fileinfo completes successfully, showing detailed information for the active backup.
  • Running tdpsqlc q tsm dbname full /all also succeeds, showing cursory information for all backups of the database.
  • Running tdpsqlc q tsm dbname full /fileinfo /all fails with ACO0151E Errors occurred while processing the request.

Resolving The Problem

The above failure for the "tdpsqlc q tsm dbname full /fileinfo /all" is not indicative of the APARs.

The data for old backups is often stored on tape, and the Tivoli Storage Manager Server needs time to mount and read tapes to display detailed information for these backups, including the physical file name, logical name, and space allocated.

The Mountwait parameter has a default value of no. Explicitly setting it to yes in the command will allow the query to complete:


    tdpsqlc q tsm dbname full /fileinfo /all /mountwait=yes

[{"Product":{"code":"SSTFZR","label":"Tivoli Storage Manager for Databases"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS SQL","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3;6.4;7.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21883398